Should Using Wordpress Make You Think Again

WORDPRESS is a very good platform for websites and blogs. But I think it has become too successful. The reason why is because it is a prime target for hackers.

For some time I have been writing about the flaws in the use of Wordpress by unsuspecting and innocent users. 

In November 2012 I wrote about Your Blog Security. This was followed shortly afterwards by Wordpress Vulnerabilities and What To Do.

Then in May 2014 I revisited this topic with Protect Your Blog From Hackers.

So here we are in 2015, and what has changed? 


Wordpress sites are an even greater target

Consider the following;

  • As of April 2015 there are more than 74.6 million Wordpress sites
  • It is the world’s most popular Content Management System (CMS) used by 23.8% of all websites
  • There are 29,000 Wordpress Plugins that have been downloaded more than 286 million times, mind-boggling figures!
  • Wordpress is the most popular business website platform
  • Wordpress.com (as distinct from the free Wordpress.org) gets more visitors than Amazon
  • There are 40 translations of Wordpress
  • According to Arstechnica, there are “as many as 1 million+ Wordpress sites"  with the plugin Slimstat that exposes them to an attack by hackers.

And there’s more information like this. What it means should be of great concern to all Wordpress users.

Not only are tens of thousands of Wordpress sites being hacked each year, but Google has black-listed thousands of malware-infected Wordpress domains.

But the really big one is this …  The Hacker News has said the following;

According to the FBI, ISIS sympathisers are targeting Wordpress sites and the communications platforms of commercial entities, news organisations, federal/state/local governments, religious institutions, foreign governments, and a number of other domestic and international websites.


The issue is predominantly two-fold;

  • it is about individual website owners who fail to frequently update Wordpress and the plugins that they have used
  • unsuspecting people getting caught in scam sites such as fake government websites, and subsequently revealing their personal and payment details

Be vigilant, always show great care, always apply the best protection systems for your website or blog that you can.


How to fix Wordpress vulnerabilities

Hacking is very likely to increase alarmingly into the future, so Wordpress users need to be constantly vigilant.

If you must use Wordpress, or are unable to use another platform, the absolute best way to protect your WP site is to use …

                                      BLOG DEFENDER 2016


Updated 21 Dec 2016

© Copyright 2011-2016   All Rights Reserved      Des Menz          Site map      About      Contact       
Privacy Policy    Terms of Service & Conditions of Use    Anti-Spam Policy    Disclaimer    DMCA Compliance    FTC Compliance    Social Media Disclosure